// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Z][a-z'’]*(?:\s+[A-Z][a-z'’]*)+").unwrap();
let string = "The Cow goes moo, and the Dog's Name, is orange\"
The mother-daughter bakery, Molly’s Munchies, was founded in 2009";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}