re = /\b[A-Z][a-z'’]*(?:\s+[A-Z][a-z'’]*)+/m
str = 'The Cow goes moo, and the Dog\'s Name, is orange"
The mother-daughter bakery, Molly’s Munchies, was founded in 2009'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end