using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=https://)|(?<=http://))(?:(?!www\.)[^\W_]+(?:-[^\W_]+)?\.)*[^\W-_]+(?=$|[/?#])";
string input = @"https://some.something.com
https://www.something.com
http://some.something.com
http://www.something.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}