$re = '~(?:(?<=https://)|(?<=http://))(?:(?!www\.)[^\W_]+(?:-[^\W_]+)?\.)*[^\W-_]+(?=$|[/?#])~m';
$str = 'https://some.something.com
https://www.something.com
http://some.something.com
http://www.something.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);