re = /(?:(?<=https:\/\/)|(?<=http:\/\/))(?:(?!www\.)[^\W_]+(?:-[^\W_]+)?\.)*[^\W-_]+(?=$|[\/?#])/m
str = 'https://some.something.com
https://www.something.com
http://some.something.com
http://www.something.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end