const regex = new RegExp('(?:(?<=https://)|(?<=http://))(?:(?!www\\.)[^\\W_]+(?:-[^\\W_]+)?\\.)*[^\\W-_]+(?=$|[/?#])', 'gm')
const str = `https://some.something.com
https://www.something.com
http://some.something.com
http://www.something.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}