#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*["!'^+%&/()=?_\-*\\{}[\]$#£é€@])(?=.{8,}))"
Local $sString = "ASDFASDTabc234" & @CRLF & _
"ASDFASDTabc234"" & @CRLF & _
"ASDFASDTabc234!" & @CRLF & _
"ASDFASDTabc234'" & @CRLF & _
"ASDFASDTabc234^" & @CRLF & _
"ASDFASDTabc234+" & @CRLF & _
"ASDFASDTabc234%" & @CRLF & _
"ASDFASDTabc234&" & @CRLF & _
"ASDFASDTabc234/" & @CRLF & _
"ASDFASDTabc234(" & @CRLF & _
"ASDFASDTabc234)" & @CRLF & _
"ASDFASDTabc234=" & @CRLF & _
"ASDFASDTabc234?" & @CRLF & _
"ASDFASDTabc234_" & @CRLF & _
"ASDFASDTabc234-" & @CRLF & _
"ASDFASDTabc234*" & @CRLF & _
"ASDFASDTabc234\" & @CRLF & _
"ASDFASDTabc234{" & @CRLF & _
"ASDFASDTabc234}" & @CRLF & _
"ASDFASDTabc234[" & @CRLF & _
"ASDFASDTabc234]" & @CRLF & _
"ASDFASDTabc234$" & @CRLF & _
"ASDFASDTabc234#" & @CRLF & _
"ASDFASDTabc234£" & @CRLF & _
"ASDFASDTabc234é" & @CRLF & _
"ASDFASDTabc234€" & @CRLF & _
"ASDFASDTabc234@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")