re = /^((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*["!'^+%&\/()=?_\-*\\{}[\]$#£é€@])(?=.{8,}))/m
str = 'ASDFASDTabc234
ASDFASDTabc234"
ASDFASDTabc234!
ASDFASDTabc234\'
ASDFASDTabc234^
ASDFASDTabc234+
ASDFASDTabc234%
ASDFASDTabc234&
ASDFASDTabc234/
ASDFASDTabc234(
ASDFASDTabc234)
ASDFASDTabc234=
ASDFASDTabc234?
ASDFASDTabc234_
ASDFASDTabc234-
ASDFASDTabc234*
ASDFASDTabc234\\
ASDFASDTabc234{
ASDFASDTabc234}
ASDFASDTabc234[
ASDFASDTabc234]
ASDFASDTabc234$
ASDFASDTabc234#
ASDFASDTabc234£
ASDFASDTabc234é
ASDFASDTabc234€
ASDFASDTabc234@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end