import Foundation
let pattern = ##"^((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*["!'^+%&/()=?_\-*\\{}[\]$#£é€@])(?=.{8,}))"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ASDFASDTabc234
ASDFASDTabc234"
ASDFASDTabc234!
ASDFASDTabc234'
ASDFASDTabc234^
ASDFASDTabc234+
ASDFASDTabc234%
ASDFASDTabc234&
ASDFASDTabc234/
ASDFASDTabc234(
ASDFASDTabc234)
ASDFASDTabc234=
ASDFASDTabc234?
ASDFASDTabc234_
ASDFASDTabc234-
ASDFASDTabc234*
ASDFASDTabc234\
ASDFASDTabc234{
ASDFASDTabc234}
ASDFASDTabc234[
ASDFASDTabc234]
ASDFASDTabc234$
ASDFASDTabc234#
ASDFASDTabc234£
ASDFASDTabc234é
ASDFASDTabc234€
ASDFASDTabc234@
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)