$re = '/^((?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])(?=.*["!\'^+%&/()=?_\-*\\\\{}[\]$#£é€@])(?=.{8,}))/m';
$str = 'ASDFASDTabc234
ASDFASDTabc234"
ASDFASDTabc234!
ASDFASDTabc234\'
ASDFASDTabc234^
ASDFASDTabc234+
ASDFASDTabc234%
ASDFASDTabc234&
ASDFASDTabc234/
ASDFASDTabc234(
ASDFASDTabc234)
ASDFASDTabc234=
ASDFASDTabc234?
ASDFASDTabc234_
ASDFASDTabc234-
ASDFASDTabc234*
ASDFASDTabc234\\
ASDFASDTabc234{
ASDFASDTabc234}
ASDFASDTabc234[
ASDFASDTabc234]
ASDFASDTabc234$
ASDFASDTabc234#
ASDFASDTabc234£
ASDFASDTabc234é
ASDFASDTabc234€
ASDFASDTabc234@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);