using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id""\s*:\s*""([\w=]*)""";
string input = @"{
""wallets"" : [ {
""id"" : ""eyJpZGVudGl0eSI6WzQ4LDQyLDQ4LDUsNiwzLDQzLDEwMSwxMTIsMywzMywwLC0zMCw4MSwxMDQsMCw2NywtMTcsNDcsLTM0LC0yNiwtNDksLTg0LDkxLC0xMDgsMTcsMjUsMTksLTcxLC0xMTcsLTEwMywzNSwtMjEsNDAsLTcyLDY3LDEwNSwxMCwtNDAsMTE3LC0xMTEsLTEwLDExNiwtNThdLCJ2ZXJzaW9uIjoiMC4xLjEifQ==""
} ]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}