// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)id"\s*:\s*"([\w=]*)""#).unwrap();
let string = "{
\"wallets\" : [ {
\"id\" : \"eyJpZGVudGl0eSI6WzQ4LDQyLDQ4LDUsNiwzLDQzLDEwMSwxMTIsMywzMywwLC0zMCw4MSwxMDQsMCw2NywtMTcsNDcsLTM0LC0yNiwtNDksLTg0LDkxLC0xMDgsMTcsMjUsMTksLTcxLC0xMTcsLTEwMywzNSwtMjEsNDAsLTcyLDY3LDEwNSwxMCwtNDAsMTE3LC0xMTEsLTEwLDExNiwtNThdLCJ2ZXJzaW9uIjoiMC4xLjEifQ==\"
} ]
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}