$re = '/id"\s*:\s*"([\w=]*)"/m';
$str = '{
"wallets" : [ {
"id" : "eyJpZGVudGl0eSI6WzQ4LDQyLDQ4LDUsNiwzLDQzLDEwMSwxMTIsMywzMywwLC0zMCw4MSwxMDQsMCw2NywtMTcsNDcsLTM0LC0yNiwtNDksLTg0LDkxLC0xMDgsMTcsMjUsMTksLTcxLC0xMTcsLTEwMywzNSwtMjEsNDAsLTcyLDY3LDEwNSwxMCwtNDAsMTE3LC0xMTEsLTEwLDExNiwtNThdLCJ2ZXJzaW9uIjoiMC4xLjEifQ=="
} ]
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);