const regex = /(?<!")(Level\s\d+)(?!")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!")(Level\\s\\d+)(?!")', 'gm')
const str = `This is a test with various "Level 2" and Level 5 and stuff.
Not sure how to treat "Level 2 or Level 5" though.
Also capturing Level 12 would be nice I guess? (Not "Level 12" of course though)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}