import re
regex = re.compile(r"(?<!\")(Level\s\d+)(?!\")", flags=re.MULTILINE)
test_str = ("This is a test with various \"Level 2\" and Level 5 and stuff.\n\n"
"Not sure how to treat \"Level 2 or Level 5\" though.\n\n"
"Also capturing Level 12 would be nice I guess? (Not \"Level 12\" of course though)\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")