using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?example.*?\/a>";
string input = @"<a href=""http://example.com"">
1rer</a>vcbn
<a
href=""http://example.com/fdfdsfds"">fdsfsdfsd</a>cvbn
<a class=""fff"" href=""http://example.com/dsdaas"">3e2fdf fdsfds</a>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}