const regex = /<a.*?example.*?\/a>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.*?example.*?\\\/a>', 'gs')
const str = `<a href="http://example.com">
1rer</a>vcbn
<a
href="http://example.com/fdfdsfds">fdsfsdfsd</a>cvbn
<a class="fff" href="http://example.com/dsdaas">3e2fdf fdsfds</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}