import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*?example.*?\\/a>";
final String string = "<a href=\"http://example.com\">\n"
+ "1rer</a>vcbn\n"
+ "<a \n"
+ "href=\"http://example.com/fdfdsfds\">fdsfsdfsd</a>cvbn\n"
+ "<a class=\"fff\" href=\"http://example.com/dsdaas\">3e2fdf fdsfds</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}