// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<a.*?example.*?\/a>").unwrap();
let string = "<a href=\"http://example.com\">
1rer</a>vcbn
<a
href=\"http://example.com/fdfdsfds\">fdsfsdfsd</a>cvbn
<a class=\"fff\" href=\"http://example.com/dsdaas\">3e2fdf fdsfds</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}