#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?\:\/\/)?[\w.]+"
Local $sString = "https://site.ru" & @CRLF & _
"http://site.ru" & @CRLF & _
"http://site.xyz/bla" & @CRLF & _
"https://site.com/blabla/test" & @CRLF & _
"https://en.site.com/blabla/test" & @CRLF & _
"site.ru/blabla/test/test2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")