import re
regex = re.compile(r"^(?:https?\:\/\/)?[\w.]+", flags=re.MULTILINE)
test_str = ("https://site.ru\n"
"http://site.ru\n"
"http://site.xyz/bla\n"
"https://site.com/blabla/test\n"
"https://en.site.com/blabla/test\n"
"site.ru/blabla/test/test2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")