import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?\\:\\/\\/)?[\\w.]+";
final String string = "https://site.ru\n"
+ "http://site.ru\n"
+ "http://site.xyz/bla\n"
+ "https://site.com/blabla/test\n"
+ "https://en.site.com/blabla/test\n"
+ "site.ru/blabla/test/test2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}