package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{4}\b\+?`)
var str = `Please message mpg of jazz 2014 and 2015+ to my mobile number +123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}