$re = '/\b\d{4}\b\+?/m';
$str = 'Please message mpg of jazz 2014 and 2015+ to my mobile number +123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);