re = /\b\d{4}\b\+?/m
str = 'Please message mpg of jazz 2014 and 2015+ to my mobile number +123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end