const regex = /\b\d{4}\b\+?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\b\\+?', 'gm')
const str = `Please message mpg of jazz 2014 and 2015+ to my mobile number +123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}