#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$"
Local $sString = "5" & @CRLF & _
"50" & @CRLF & _
"500" & @CRLF & _
"5000" & @CRLF & _
"50000" & @CRLF & _
"500000" & @CRLF & _
"4999999" & @CRLF & _
"5000000" & @CRLF & _
"6000000" & @CRLF & _
"7000000" & @CRLF & _
"8000000" & @CRLF & _
"8999999" & @CRLF & _
"9000000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")