# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$"
test_str = ("5\n"
"50\n"
"500\n"
"5000\n"
"50000\n"
"500000\n"
"4999999\n"
"5000000\n"
"6000000\n"
"7000000\n"
"8000000\n"
"8999999\n"
"9000000\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.