package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([5-8]\d\d\d\d\d\d|[8-8]\d\d\d\d\d\d|8999999)$`)
var str = `5
50
500
5000
50000
500000
4999999
5000000
6000000
7000000
8000000
8999999
9000000
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}