import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[TestCaseSource\\(\\\"ALM\\\"\\)\\](.*|\\n)*\\}";
final String string = " [TestCaseSource(\"ALM\")]\n"
+ " public void AccountFinancialTest(string testSetId)\n"
+ " {\n"
+ " TestCaseDetails tcd = new TestCaseDetails();\n"
+ " tcd.TestSetId = testSetId;\n"
+ " tcd.TestFeature = \"CBSD-9451 C3 FI BSA financial attributes migration\";\n"
+ " tcd.TestName = \"CBSD-13027 TEST: Lean FT tests for financial sequence part 2\";\n"
+ " tcd.TestCase = \"AccountFinancial_BALANCE\";\n\n"
+ " env = \"DEV\";\n"
+ " system = \"DATASTAGE\";\n"
+ " team = \"TRANSFORMERS\";\n"
+ " tvs = new TestValidationService();\n"
+ " Credentials.Server = GetFieldValue(\"SERVER\");\n"
+ " Credentials.DefaultDataStageProject = GetFieldValue(\"PROJECT\");\n"
+ " Credentials.Domain = GetFieldValue(\"DOMAIN\");\n\n"
+ " T24connectionstring = GetFieldValue(\"T24CONNECTIONSTRING\");\n"
+ " T24schema = GetFieldValue(\"T24SCHEMA\");\n\n"
+ " Db2connectionstring = GetFieldValue(\"DB2CONNECTION\");\n"
+ " Db2Schema = GetFieldValue(\"Db2Schema\");\n\n"
+ " DoTest(TestFinancialSequence);\n"
+ " }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}