const regex = /\[TestCaseSource\(\"ALM\"\)\](.*|\n)*\}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[TestCaseSource\\(\\"ALM\\"\\)\\](.*|\\n)*\\}', 'gm')
const str = ` [TestCaseSource("ALM")]
public void AccountFinancialTest(string testSetId)
{
TestCaseDetails tcd = new TestCaseDetails();
tcd.TestSetId = testSetId;
tcd.TestFeature = "CBSD-9451 C3 FI BSA financial attributes migration";
tcd.TestName = "CBSD-13027 TEST: Lean FT tests for financial sequence part 2";
tcd.TestCase = "AccountFinancial_BALANCE";
env = "DEV";
system = "DATASTAGE";
team = "TRANSFORMERS";
tvs = new TestValidationService();
Credentials.Server = GetFieldValue("SERVER");
Credentials.DefaultDataStageProject = GetFieldValue("PROJECT");
Credentials.Domain = GetFieldValue("DOMAIN");
T24connectionstring = GetFieldValue("T24CONNECTIONSTRING");
T24schema = GetFieldValue("T24SCHEMA");
Db2connectionstring = GetFieldValue("DB2CONNECTION");
Db2Schema = GetFieldValue("Db2Schema");
DoTest(TestFinancialSequence);
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}