re = /\[TestCaseSource\(\"ALM\"\)\](.*|\n)*\}/m
str = ' [TestCaseSource("ALM")]
public void AccountFinancialTest(string testSetId)
{
TestCaseDetails tcd = new TestCaseDetails();
tcd.TestSetId = testSetId;
tcd.TestFeature = "CBSD-9451 C3 FI BSA financial attributes migration";
tcd.TestName = "CBSD-13027 TEST: Lean FT tests for financial sequence part 2";
tcd.TestCase = "AccountFinancial_BALANCE";
env = "DEV";
system = "DATASTAGE";
team = "TRANSFORMERS";
tvs = new TestValidationService();
Credentials.Server = GetFieldValue("SERVER");
Credentials.DefaultDataStageProject = GetFieldValue("PROJECT");
Credentials.Domain = GetFieldValue("DOMAIN");
T24connectionstring = GetFieldValue("T24CONNECTIONSTRING");
T24schema = GetFieldValue("T24SCHEMA");
Db2connectionstring = GetFieldValue("DB2CONNECTION");
Db2Schema = GetFieldValue("Db2Schema");
DoTest(TestFinancialSequence);
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end