use strict;
my $str = ' [TestCaseSource("ALM")]
public void AccountFinancialTest(string testSetId)
{
TestCaseDetails tcd = new TestCaseDetails();
tcd.TestSetId = testSetId;
tcd.TestFeature = "CBSD-9451 C3 FI BSA financial attributes migration";
tcd.TestName = "CBSD-13027 TEST: Lean FT tests for financial sequence part 2";
tcd.TestCase = "AccountFinancial_BALANCE";
env = "DEV";
system = "DATASTAGE";
team = "TRANSFORMERS";
tvs = new TestValidationService();
Credentials.Server = GetFieldValue("SERVER");
Credentials.DefaultDataStageProject = GetFieldValue("PROJECT");
Credentials.Domain = GetFieldValue("DOMAIN");
T24connectionstring = GetFieldValue("T24CONNECTIONSTRING");
T24schema = GetFieldValue("T24SCHEMA");
Db2connectionstring = GetFieldValue("DB2CONNECTION");
Db2Schema = GetFieldValue("Db2Schema");
DoTest(TestFinancialSequence);
}';
my $regex = qr/\[TestCaseSource\(\"ALM\"\)\](.*|\n)*\}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}