#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[^\/\n]*\/){5})(?:(?:\/[A-Za-z0-9-]+){1,4}\/?|\/)$"
Local $sString = "#match: YES" & @CRLF & _
"/" & @CRLF & _
"/trip-001" & @CRLF & _
"/trip-001/" & @CRLF & _
"/trip-001/summer-2019" & @CRLF & _
"/trip-001/summer-2019/" & @CRLF & _
"/trip-001/summer-2019/ibiza-001/" & @CRLF & _
"/trip-001/summer-2019/ibiza-001/PICT-001" & @CRLF & _
"" & @CRLF & _
"#match: NO" & @CRLF & _
"//" & @CRLF & _
"trip-001" & @CRLF & _
"trip-001/" & @CRLF & _
"trip-001/summer-2019" & @CRLF & _
"trip-001/summer-2019/" & @CRLF & _
"trip-001/summer-2019/ibiza-001/" & @CRLF & _
"trip-001/summer-2019/ibiza-001/PICT-001" & @CRLF & _
"" & @CRLF & _
"/trip-001/summer-2019/ibiza-001/PICT-001/" & @CRLF & _
"/trip-001/summer-2019/ibiza-001/whatever-987/PICT001" & @CRLF & _
"/trip-001/summer-2019/ibiza-001/whatever-987/PICT001/" & @CRLF & _
"" & @CRLF & _
"trip-001/summer-2019/ibiza-001/PICT-001/" & @CRLF & _
"trip-001/summer-2019/ibiza-001/whatever-987/PICT001" & @CRLF & _
"trip-001/summer-2019/ibiza-001/whatever-987/PICT001/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")