import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:[^\\/\\n]*\\/){5})(?:(?:\\/[A-Za-z0-9-]+){1,4}\\/?|\\/)$";
final String string = "#match: YES\n"
+ "/\n"
+ "/trip-001\n"
+ "/trip-001/\n"
+ "/trip-001/summer-2019\n"
+ "/trip-001/summer-2019/\n"
+ "/trip-001/summer-2019/ibiza-001/\n"
+ "/trip-001/summer-2019/ibiza-001/PICT-001\n\n"
+ "#match: NO\n"
+ "//\n"
+ "trip-001\n"
+ "trip-001/\n"
+ "trip-001/summer-2019\n"
+ "trip-001/summer-2019/\n"
+ "trip-001/summer-2019/ibiza-001/\n"
+ "trip-001/summer-2019/ibiza-001/PICT-001\n\n"
+ "/trip-001/summer-2019/ibiza-001/PICT-001/\n"
+ "/trip-001/summer-2019/ibiza-001/whatever-987/PICT001\n"
+ "/trip-001/summer-2019/ibiza-001/whatever-987/PICT001/\n\n"
+ "trip-001/summer-2019/ibiza-001/PICT-001/\n"
+ "trip-001/summer-2019/ibiza-001/whatever-987/PICT001\n"
+ "trip-001/summer-2019/ibiza-001/whatever-987/PICT001/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}