import re
regex = re.compile(r"^(?!(?:[^\/\n]*\/){5})(?:(?:\/[A-Za-z0-9-]+){1,4}\/?|\/)$", flags=re.MULTILINE)
test_str = ("#match: YES\n"
"/\n"
"/trip-001\n"
"/trip-001/\n"
"/trip-001/summer-2019\n"
"/trip-001/summer-2019/\n"
"/trip-001/summer-2019/ibiza-001/\n"
"/trip-001/summer-2019/ibiza-001/PICT-001\n\n"
"#match: NO\n"
"//\n"
"trip-001\n"
"trip-001/\n"
"trip-001/summer-2019\n"
"trip-001/summer-2019/\n"
"trip-001/summer-2019/ibiza-001/\n"
"trip-001/summer-2019/ibiza-001/PICT-001\n\n"
"/trip-001/summer-2019/ibiza-001/PICT-001/\n"
"/trip-001/summer-2019/ibiza-001/whatever-987/PICT001\n"
"/trip-001/summer-2019/ibiza-001/whatever-987/PICT001/\n\n"
"trip-001/summer-2019/ibiza-001/PICT-001/\n"
"trip-001/summer-2019/ibiza-001/whatever-987/PICT001\n"
"trip-001/summer-2019/ibiza-001/whatever-987/PICT001/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")