#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,3}(?:\.\d{3})+,\d{2}$"
Local $sString = "1.000.000,00" & @CRLF & _
"10.000,00" & @CRLF & _
"1.000,00" & @CRLF & _
"999.999.999.999.999.999,00" & @CRLF & _
"1,567,00" & @CRLF & _
"12.45,00" & @CRLF & _
"1.456.234.123,00,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")