re = /\d{1,3}(?:\.\d{3})+,\d{2}$/m
str = '1.000.000,00
10.000,00
1.000,00
999.999.999.999.999.999,00
1,567,00
12.45,00
1.456.234.123,00,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end