// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{1,3}(?:\.\d{3})+,\d{2}$").unwrap();
let string = "1.000.000,00
10.000,00
1.000,00
999.999.999.999.999.999,00
1,567,00
12.45,00
1.456.234.123,00,00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}