package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,3}(?:\.\d{3})+,\d{2}$`)
var str = `1.000.000,00
10.000,00
1.000,00
999.999.999.999.999.999,00
1,567,00
12.45,00
1.456.234.123,00,00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}