#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bfall out\b"
Local $sString = "They are worried about nuclear fall out and radiation." & @CRLF & _
"There's fall out, and then there's radiation." & @CRLF & _
"In Nagasaki one of the biggest concerns was fall out." & @CRLF & _
"One of the best games of the 2000s was "fall out"." & @CRLF & _
"That would fall outside of your purview."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")