import Foundation
let pattern = #"\bfall out\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
They are worried about nuclear fall out and radiation.
There's fall out, and then there's radiation.
In Nagasaki one of the biggest concerns was fall out.
One of the best games of the 2000s was "fall out".
That would fall outside of your purview.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)