// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bfall out\b").unwrap();
let string = "They are worried about nuclear fall out and radiation.
There's fall out, and then there's radiation.
In Nagasaki one of the biggest concerns was fall out.
One of the best games of the 2000s was \"fall out\".
That would fall outside of your purview.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}