use strict;
my $str = 'By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which...
[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids.
Much of the gravel is used [b]"as is" ([i]соl.[/i]) for building roads.
Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult.
[b](As) viewed from the top ([i]or[/i] [b]from above) the insect\'s abdomen swings to the top as if it were a rudder.';
my $regex = qr/\[b\](?!\w*.\[\/b\])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}