import re
regex = re.compile(r"\[b\](?!\w*.\[\/b\])", flags=re.MULTILINE)
test_str = ("By purely mathematical reasoning it is possible [b]to demonstrate ([i]or[/i] [b]prove) a theorem which...\n"
"[b]There is little point ([i]or[/i] [b]sense) in listing all of the known amino acids.\n"
"Much of the gravel is used [b]\"as is\" ([i]соl.[/i]) for building roads.\n"
"Tuberculin test [b]is of doubtful value in the elderly since its interpretation is very difficult.\n"
"[b](As) viewed from the top ([i]or[/i] [b]from above) the insect's abdomen swings to the top as if it were a rudder.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")