using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-;\w\ \.\/\'\d\(\)\&]+) - ([\w+\ \.\-]+)";
string input = @"<a id=""test"">One & -Two - Three</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}