re = /([-;\w\ \.\/\'\d\(\)\&]+) - ([\w+\ \.\-]+)/
str = '<a id="test">One & -Two - Three</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end