package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([-;\w\ \.\/\'\d\(\)\&]+) - ([\w+\ \.\-]+)`)
var str = `<a id="test">One & -Two - Three</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}