$re = '/([-;\w\ \.\/\'\d\(\)\&]+) - ([\w+\ \.\-]+)/';
$str = '<a id="test">One & -Two - Three</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);