using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(coffee|pots?)(?:\n)";
string input = @"import re
string = """"
All I want is a proper cup of coffee
Made in a proper copper coffee pot
I may be off my dot
But I want a cup of coffee
From a proper coffee pot
Tin coffee pots and iron coffee pots
They’re no use to me
If I can’t have a proper cup of coffee
In a proper copper coffee pot
I’ll have a cup of tea.
""""
pattern = r'coffee\n|pot\n|pots\n'
print(re.findall(pattern, string))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}